7 Απριλίου 2010

Απαντήσεις επαναληπτικές ημερήσια 2004

ΘΕΜΑ 1ο
Α.   1 – Σ, 2 – Σ, 3 – Λ, 4 – Σ, 5 – Λ
Β.   1 – β, γ                   2 – δ                             3 – α
Γ.   1 – Λ, 2 – Σ, 3 – Λ, 4 – Σ, 5 – Σ
Δ.   1.   Τρεις (3) φορές               2.         Μία (1) φορά
      3.   Άπειρες φορές               4.         Καμία φορά
Ε.   1.   Σχ. βιβλίο, παρ. 6.3, σελ. 130     2.         Σχ. βιβλίο, παρ. 6.3, σελ. 130
      3.   Σχ. βιβλίο, παρ. 6.3, σελ. 130     4.         Σχ. βιβλίο, παρ. 6.3, σελ. 131
ΘΕΜΑ 2ο
α)   Για Α=3:

A
B
C
D
E
F
G
Αρχικές τιμές
3
4
2
1η επανάληψη
3
14
3

3
14
3
7
0
Εντός του ΑΝ
3
14
3
7
0
28
0
1η επανάληψη
3
14
3
7
0
2
1
2η επανάληψη
3
14
3
7
0
0
2
14
7
Τέλειος αριθμός: 28
2
β)   Για Α=4:

A
B
C
D
E
F
G
Αρχικές τιμές
4
4
2
1η επανάληψη
4
14
3
2η επανάληψη
4
194
4

4
194
4
15
14
14
194
15
ΘΕΜΑ 3ο
ΑΛΓΟΡΙΘΜΟΣ Βαθμολογία
ΓΡΑΨΕ ‘Δώσε τους βαθμούς των τριών βαθμολογητών’
ΔΙΑΒΑΣΕ Β1, Β2, Β3
ΑΝ Β1 > Β2 ΤΟΤΕ
ΜΑΧ ¬ Β1, ΜΙΝ ¬ Β2
ΑΛΛΙΩΣ
ΜΑΧ ¬ Β2, ΜΙΝ ¬ Β1
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ ‘Μεγαλύτερος βαθμός: ’, MAX, ‘Μικρότερος βαθμός: ’, MIN
ΜΟ ß (Β1 + Β2) / 2
ΑΝ Β3 = ΜΟ ΤΟΤΕ
ΤΒ ¬ ΜΟ
            ΑΛΛΙΩΣ_ΑΝ Β3 < ΜΙΝ ΤΟΤΕ
                        ΤΒ ¬ ΜΙΝ
ΑΛΛΙΩΣ_ΑΝ Β3 > ΜΟ ΤΟΤΕ
ΤΒ ¬ (ΜΑΧ + Β3) / 2
ΑΛΛΙΩΣ
ΤΒ ¬ (ΜΙΝ + Β3) / 2
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ ‘Ο τελικός βαθμός του γραπτού είναι: ’, ΤΒ
ΤΕΛΟΣ Βαθμολογία
ΘΕΜΑ 4ο
ΑΛΓΟΡΙΘΜΟΣ Εκλογές
            ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 15
                        ΓΡΑΨΕ ‘Δώσε όνομα κόμματος’
                        ΔΙΑΒΑΣΕ ΚΟΜΜΑ[i]
ΓΡΑΨΕ ‘Δώσε ποσοστό έγκυρων ψηφοδελτίων που έλαβε’
ΔΙΑΒΑΣΕ ΠΟΣ[i]
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            Max ¬ ΠΟΣ[1], Θέση ß 1, Sum ¬ 0
            ΓΡΑΨΕ ‘Δεν έλαβαν καμία έδρα:’
            ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 15
                        ΑΝ ΠΟΣ[i] < 3 ΤΟΤΕ
                                    ΓΡΑΨΕ ΚΟΜΜΑ[i], ΠΟΣ[i]
                        ΑΛΛΙΩΣ
                                    Sum ¬ Sum + ΠΟΣ[i]
                        ΤΕΛΟΣ_ΑΝ
                        ΑΝ ΠΟΣ[i] > Max ΤΟΤΕ
                                    Max ¬ ΠΟΣ[i], Θέση ¬ i
                        ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΓΡΑΨΕ ‘Πρώτο κόμμα: ’, ΚΟΜΜΑ[Θέση]
            ΓΡΑΨΕ ‘Άθροισμα ποσοστών κομμάτων που δικαιούνται έδρα: ’, Sum
            Συν_εδρών ¬ 0
            ΓΡΑΨΕ ‘Αριθμός εδρών που έλαβε το κάθε κόμμα:’
            ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 15
                        ΑΝ (ΠΟΣ[i] > = 3) ΚΑΙ (i < > Θέση) ΤΟΤΕ
                                    Έδρες ¬ Α_Μ(ΠΟΣ[i] * 24 / Sum)
                                    ΓΡΑΨΕ ΚΟΜΜΑ[i], Έδρες
                                    Συν_εδρών ¬ Συν_εδρών + Έδρες
                        ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            Έδρες ¬ 24 – Συν_εδρών
            ΓΡΑΨΕ ‘Έδρες πρώτου κόμματος :’, ΚΟΜΜΑ[Θέση], Έδρες
ΤΕΛΟΣ_Εκλογές

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου

Δημοσίευση σχολίου